Back to overview
Degraded

Google Sheets block issue

Jul 22 at 10:40am CEST
Affected services
Bots
Builder

Resolved
Jul 22 at 11:11am CEST

A fix was published and we are starting to see resolution in production.

Created
Jul 22 at 10:40am CEST

Google Sheets blocks are currently not working as expected. They may fail in some bots.

The authentication refresh is not working as expected.

We identified the issue and are fixing it.

This issue potentially appeared on 7/21/2025 at 4pm